Strict Standards: call_user_func() expects parameter 1 to be a valid callback, non-static method dokuwiki_TextFormatter::render() should not be called statically in /var/www/sip-router.kamailio.org/flyspray/includes/class.tpl.php on line 552 FS#496 : Dialog state changed after restart Kamailio for db_mode=REALTIME

sip-router

Strict Standards: call_user_func() expects parameter 1 to be a valid callback, non-static method dokuwiki_TextFormatter::render() should not be called statically in /var/www/sip-router.kamailio.org/flyspray/includes/class.tpl.php on line 552

SIP Router Project

Tasklist

FS#496 - Dialog state changed after restart Kamailio for db_mode=REALTIME

Attached to Project: sip-router
Opened by Seudin Kasumovic (seudin) - Wednesday, 26 November 2014, 14:56 GMT
Last edited by Daniel-Constantin Mierla (miconda) - Tuesday, 02 December 2014, 17:22 GMT
Task Type Bug Report
Category Module
Status Closed
Assigned To No-one
Operating System Linux
Severity Low
Priority Normal
Reported Version 4.2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Dialog state changed after restart Kamailio.

Kamailio dialog module parameter db_mode is set to REALTIME
modparam(”dialog”, “db_mode”, 1)

Before restart:
dialog:: hash=3921:4512

state:: 5
ref_count:: 2
timestart:: 1417012586
timeout:: 0
callid:: 1435233227@10.1.130.137
from_uri:: sip:1002@orange.voip
from_tag:: 603880624
caller_contact:: sip:1002@198.51.100.137:50508
caller_cseq:: 2
caller_route_set:: <sip:172.16.23.130;r2=on;st=on;ftag=603880624;lr>,<sip:192.0.2.130;transport=udp;r2=on;st=on;ftag=603880624;lr>
caller_bind_addr:: udp:172.16.23.130:5070
callee_bind_addr:: udp:172.16.23.130:5070
to_uri:: sip:*368@orange.voip
to_tag:: S0520657r5Ktc
callee_contact:: sip:milliwatt@127.0.0.1:5090;transport=udp
callee_cseq:: 0
callee_route_set::

After restart:
dialog:: hash=3921:4512

state:: 4
ref_count:: 2
timestart:: 1417012586
timeout:: 89692990
callid:: 1435233227@10.1.130.137
from_uri:: sip:1002@orange.voip
from_tag:: 603880624
caller_contact:: sip:1002@198.51.100.137:50508
caller_cseq:: 2
caller_route_set:: <sip:172.16.23.130;r2=on;st=on;ftag=603880624;lr>,<sip:192.0.2.130;transport=udp;r2=on;st=on;ftag=603880624;lr>
caller_bind_addr:: udp:172.16.23.130:5070
callee_bind_addr:: udp:172.16.23.130:5070
to_uri:: sip:*368@orange.voip
to_tag:: S0520657r5Ktc
callee_contact:: sip:milliwatt@127.0.0.1:5090;transport=udp
callee_cseq:: 0
callee_route_set::

version: kamailio 4.2.1 (i386/linux)
flags: STATS: Off, USE_TCP, USE_TLS, TLS_HOOKS, USE_RAW_SOCKS, DISABLE_NAGLE, USE_MCAST, DNS_IP_HACK, SHM_MEM, SHM_MMAP, PKG_MALLOC, F_MALLOC, DBG_F_MALLOC, USE_FUTEX, FAST_LOCK-ADAPTIVE_WAIT, USE_DNS_CACHE, USE_DNS_FAILOVER, USE_NAPTR, USE_DST_BLACKLIST, HAVE_RESOLV_RES
ADAPTIVE_WAIT_LOOPS=1024, MAX_RECV_BUFFER_SIZE 262144, MAX_LISTEN 16, MAX_URI_SIZE 1024, BUF_SIZE 65535, DEFAULT PKG_SIZE 8MB
poll method support: poll, epoll_lt, epoll_et, sigio_rt, select.
id:
compiled on 13:45:56 Nov 21 2014 with gcc 4.5.4

This task depends upon

Closed by  Daniel-Constantin Mierla (miconda)
Tuesday, 02 December 2014, 17:22 GMT
Reason for closing:  Not a bug
Comment by Daniel-Constantin Mierla (miconda) - Monday, 01 December 2014, 22:11 GMT
Strict Standards: call_user_func() expects parameter 1 to be a valid callback, non-static method dokuwiki_TextFormatter::render() should not be called statically in /var/www/sip-router.kamailio.org/flyspray/includes/class.tpl.php on line 552

Have you restarted immediately after receiving the BYE?

IIRC, the dialog record is no longer updated for state 5 in database, it should be just removed from there.

Comment by Seudin Kasumovic (seudin) - Tuesday, 02 December 2014, 14:46 GMT
Strict Standards: call_user_func() expects parameter 1 to be a valid callback, non-static method dokuwiki_TextFormatter::render() should not be called statically in /var/www/sip-router.kamailio.org/flyspray/includes/class.tpl.php on line 552

The problem was in "ref_count = 2". The issue was caused by custom module. Please close.

Thanks,
Seudin

Loading...