Strict Standards: call_user_func() expects parameter 1 to be a valid callback, non-static method dokuwiki_TextFormatter::render() should not be called statically in /var/www/sip-router.kamailio.org/flyspray/includes/class.tpl.php on line 552 FS#502 : To disable sslv3 in kamailio and allow all other TLS method.

sip-router

Strict Standards: call_user_func() expects parameter 1 to be a valid callback, non-static method dokuwiki_TextFormatter::render() should not be called statically in /var/www/sip-router.kamailio.org/flyspray/includes/class.tpl.php on line 552

SIP Router Project

Tasklist

FS#502 - To disable sslv3 in kamailio and allow all other TLS method.

Attached to Project: sip-router
Opened by Varghese Paul (varghesepaul87) - Tuesday, 16 December 2014, 11:18 GMT
Last edited by Daniel-Constantin Mierla (miconda) - Friday, 02 January 2015, 10:26 GMT
Task Type Feature Request
Category Modules kamailio
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version Development
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi all,

We are trying to remove the SSL3 support from our kamailio due to poodle attack.

kamailio -v
version: kamailio 4.2.1 (x86_64/linux)

modparam(”tls”, “tls_method”, “SSLv23”)

Currently we are using the above method and we can see that it will support following ssl methods sslv3,tlsv1,tlsv1.1 and tlsv1.2.

Is it possible in kamailio to disable only sslv3 and allow all other tls version (tlsv1,tlsv1.1 and tlsv1.2) ?. If not which is the common suggested version in kamailio to avoid ssl negotiation ?

This task depends upon

Closed by  Daniel-Constantin Mierla (miconda)
Friday, 02 January 2015, 10:26 GMT
Reason for closing:  Implemented
Additional comments about closing:  I implemented on master branch. See the README for the options. Feedback on testing would be appreciated. If not working, open a new issue on github project.

Loading...